mirror of
https://github.com/andwati/zitadel.git
synced 2026-11-01 20:02:15 +00:00
chore: deps update (#11968)
# Which Problems Are Solved This pr updates major and minor dependencies and is the first step on getting our dependabot alerts cut down. # How the Problems Are Solved Depedency updates across the board eg: - Upgrade Angular to v21 - Upgrade next.js to v16.2 - Upgrade tailwind to v4 in the login - Upgrade vitest to v4 in the login This is an uncompleted list refer to the changed files for a full overview of all the updates. # Additional Changes Migrated all control flow in the console to the modern control flow syntax. Fixed the dependsOn setting for the @zitadel/login:test-unit nx target. # Additional Context - Closes https://github.com/zitadel/zitadel/issues/11274 --------- Co-authored-by: Max Peintner <[email protected]>
This commit is contained in:
+15
-15
@@ -25,9 +25,9 @@
|
||||
"@headlessui/react": "^2.2.9",
|
||||
"@heroicons/react": "2.2.0",
|
||||
"@inkeep/cxkit-react": "^0.5.115",
|
||||
"@scalar/api-reference": "^1.44.23",
|
||||
"@shikijs/rehype": "^3.22.0",
|
||||
"@shikijs/types": "^3.22.0",
|
||||
"@scalar/api-reference": "^1.49.8",
|
||||
"@shikijs/rehype": "^3.23.0",
|
||||
"@shikijs/types": "^3.23.0",
|
||||
"@types/js-yaml": "^4.0.9",
|
||||
"clsx": "2.1.1",
|
||||
"fumadocs-core": "16.6.15",
|
||||
@@ -36,41 +36,41 @@
|
||||
"fumadocs-ui": "16.6.15",
|
||||
"js-yaml": "^4.1.1",
|
||||
"lucide-react": "^0.574.0",
|
||||
"mixpanel-browser": "^2.74.0",
|
||||
"mixpanel-browser": "^2.77.0",
|
||||
"next": "16.1.6",
|
||||
"next-themes": "^0.4.6",
|
||||
"react": "^19.2.4",
|
||||
"react-copy-to-clipboard": "^5.1.0",
|
||||
"react-copy-to-clipboard": "^5.1.1",
|
||||
"react-dom": "^19.2.4",
|
||||
"react-google-charts": "^5.2.1",
|
||||
"shiki": "^3.22.0",
|
||||
"shiki": "^3.23.0",
|
||||
"tailwind-merge": "^3.5.0",
|
||||
"vanilla-cookieconsent": "3.1.0",
|
||||
"zod": "^4.3.6"
|
||||
},
|
||||
"devDependencies": {
|
||||
"@eslint/js": "^10.0.1",
|
||||
"@tailwindcss/postcss": "^4.1.18",
|
||||
"@tailwindcss/postcss": "^4.2.2",
|
||||
"@tailwindcss/typography": "^0.5.19",
|
||||
"@types/mdx": "^2.0.13",
|
||||
"@types/node": "^25.2.3",
|
||||
"@types/node": "^25.5.0",
|
||||
"@types/react": "^19.2.14",
|
||||
"@types/react-dom": "^19.2.3",
|
||||
"@typescript-eslint/eslint-plugin": "^8.57.0",
|
||||
"@typescript-eslint/parser": "^8.57.0",
|
||||
"eslint": "^10.0.0",
|
||||
"@typescript-eslint/eslint-plugin": "^8.58.0",
|
||||
"@typescript-eslint/parser": "^8.58.0",
|
||||
"eslint": "^10.1.0",
|
||||
"eslint-config-prettier": "^10.1.8",
|
||||
"eslint-import-resolver-typescript": "^4.4.4",
|
||||
"eslint-plugin-import": "^2.32.0",
|
||||
"eslint-plugin-mdx": "^3.7.0",
|
||||
"glob": "^13.0.5",
|
||||
"globals": "^17.3.0",
|
||||
"glob": "^13.0.6",
|
||||
"globals": "^17.4.0",
|
||||
"next-validate-link": "^1.6.4",
|
||||
"postcss": "^8.5.6",
|
||||
"postcss": "^8.5.8",
|
||||
"raw-loader": "^4.0.2",
|
||||
"remark-heading-id": "^1.0.1",
|
||||
"semver": "^7.7.4",
|
||||
"tailwindcss": "^4.1.18",
|
||||
"tailwindcss": "^4.2.2",
|
||||
"tailwindcss-animate": "^1.0.7",
|
||||
"tsx": "^4.21.0",
|
||||
"typescript": "^5.9.3",
|
||||
|
||||
Reference in New Issue
Block a user